ERROR with MAX_EDGE_LINES



  • Hello and Welcome :-)

    A long time I was not here...

    I have a "little" but VERY UNCONSCIOUS problem with q3map2 compiler.

    --- FixTJunctions ---
    ************ ERROR ************
    MAX_EDGE_LINES

    I was searching very long time about it and everything it all comes down to the need to improve the map, because it is apparently "INCORRECT", which is not true because I have also e.g the original Fate's map: distillery_beta2.map the original map and the same error appears during compilation. I also tried latest GTKRadiant version with 2.5.17 q3map2 and still the same error.

    Please dont give me that link:
    https://etjump.com/tutorials/general-mapping-information.html

    because I have already read it few times.

    Have someone any ideas what to do? I just wanted to do yet maps but this error prevents me very well.

    Thanks in advance.
    Greetings,
    MaTeJ



  • Add this flag to compile options (BSP stage): -notjunc
    (https://en.wikibooks.org/wiki/Q3Map2/BSP#-notjunc)
    Also take a look at this: https://www.quake3world.com/forum/viewtopic.php?t=3620



  • Thank you for responde.

    I tried yet -notjunc before I write here but it causes problem with ligh compilation (long time) etc. The second arcicle I will check thank you when I will back to home at weekend.

    Everything is ok but explain me WHY i can't compile distillery map if this map is on 100% correctly made? It's playable on every servers so compilation was fine. That's is possible I have "too good" computer to do it? Or maybe win10 causes' this problem?

    Greetings,
    MaTeJ



  • idk if that map is 100% correctly made, i don't know enough of mapping but it's a pretty big map, maybe this error becomes inevitable at some point? (same case with all big maps?)
    and are you sure it was compiled with no "-notjunc" ?
    having "too good" PC or windows10 will NOT cause this problem, i'm pretty sure of that.



  • Hello again.

    As I see nobody can help me.

    Anyway, I tried to repair it by myself, as always to the goal and I reach the success.

    I write everything what you have to do when you have this error like me, as I thought my map is 99% correctly made but this error, so let's begin.

    I use to mapping GtkRadiant's version 1.4.0 and I never change it and I don't need. (the newest versions had another keyboard shortcuts and few options that made me nervous in normal uses)
    I had the latest version of q3map2 2.5.16. WIth 2.5.17 when I tried, it also make this error MAX_EDGE_LINES so I decided to install NetRadiant, because with NetRadiant we get q3map2 2.5.17n version and what's happened when I try compile my map by using this compiler? Everything finished correctly, BUT file*.map from version GTK 1.4 when you load it in NetRadiant and vice-versa, entietes script_mover and KEY "origin" in it change brush position in your map and you have to delete it from script_mover and make new brush with texture ORIGIN connected to whole SCRIPT_MOVER, then your script_mover stay on good position (just making it like in old'school), every brush must have another ORIGIN brush, because when you add "origin" in key then problem with position on map starts again.

    https://ibb.co/3BQK7GW

    On this picture I show how the options should looks like and that, origin be not in entietes in script_mover anymore (also func_rotating, func_door_rotating etc.)

    inside common/origin is path_corner with origin on closing door position and there You must put inside this ORIGIN brush.

    I hope you understand what I tried to explain.
    If you have any questions, feel free to ask me.

    Anyway. thanks and Greetings,
    MaTeJ.


Log in to reply
 

Looks like your connection to ETJump was lost, please wait while we try to reconnect.