ETJump 2.1.0 instantly to 2.3.0 (missing files?)



  • Hello,

    I am Rick and I would like to ask a question.
    We have been running ETJump 2.1.0 past few years.
    Becouse we changed to a new linux server like a 3 weeks ago we were glad to have the newest 2.3.0 version running.
    We are able to use admin commands but it seems that we run on the old command flags, and I've been told by a guy that it might be possible that we miss certain files which were into the 2.2.0 update which our server never runned before and thus missing.

    My question is: might this be the case and if so, which files I have to grab from 2.2.0 and put into etjump and/or etmain folder of the server sftp?

    I would be pleased to hear from you.

    Best regards, Rick.

    Edit: This is the etjump folder, I'm wondering why there are 3 cgame . mp files, but I'm sort of new to these server files things, so im not sure what to remove and what to keep in there exactly.
    https://imgur.com/WGdcwfP



  • Hello Rick,

    I am quite happy to hear that TWC finally switched to 2.3.0. As for your question, no you shouldn't need to copy any files from 2.2.0 installation pack. 2.3.0 works the same way as 2.1.0 when it comes to level management, and the 2.1.0 level and user files are completely compatible with 2.3.0. Hence if you have just moved the 2.1.0 server generated files (cfg, db) from your old server, they should work properly. But i am no entirely sure i fully understand your issue, you can't change flags for the levels?

    You can remove cgame/ui libraries(dll, so), as server is only interested in qagame module, however their presence won't affect anything either, other than that server structure looks good to me.



  • Hello,

    Thanks for your help.
    I tried adding flags to levels. cfg then save file, exec file + server restart but all levels appeared to have no commands, the only thing that worked was adding commands manually to levels ingame.

    But I think I can figure the rest out from here, thanks for the help and have a nice weekend!

    Rick.


Log in to reply
 

Looks like your connection to ETJump was lost, please wait while we try to reconnect.