"vm_create on cgame failed" error



  • Hello all

    I keep getting this error when I'm trying to connect to the 999 trickjump server: VM_create on cgame failed.

    I don't have this problem on other mods.

    Does anyone have this problem or know how to fix it?

    I'm on Ubuntu btw.



  • Could be that something broke the linux build on client, I'll boot up a virtual machine and test.

    EDIT: Yes, linux client build is missing some symbols. Fixing.



  • Ok, I'll be trying again later.



  • @Zero Will this be resolved anytime soon?



  • Apparently not anytime soon.. Hopefully I'll find the time to do this sometime soon.



  • should work now.. :D



  • Hello, i have the same problem on linux mint. Tested on 2.60b and etlegacy. Same error.



  • Hey @jay1110, yeah i believe connecting to any etjump 2.2.0 server would end up with such error, unfortunately we haven't tested it pretty well before rolling it out last year :(.
    But you should be able to connect to 999 server(/connect trickjump.net) with out a problem, or any etjump 2.2.0 prior server.



  • will try that soon when iam back on my laptop, thanks for reply.



  • the 999 server printed me the same error. At 2.1.0 it worked well. thanks.



  • @jay1110 could you please upload logs for 999? Like you can just do /condump right after you will get the error message.



  • here the dump, its now from a clean etlegacy ET 32 bit. In 2.60b is also the same problem.
    https://pastebin.com/rUpHXhPu

    edit: 2.60b log: https://pastebin.com/pbxwF8ZG



  • @jay1110 Great, thanks, that was useful! Apparently you should get updated your libstdc to libstdc++6 or such, to resolve the issue :thinking:. Our binaries are compiled against g++4.9, so you gotta get the corresponding libstdc runtime lib, and yeah you should get the i386 one. I am no expert in Linux Mint, so i can't give the working command, but it probably should be something like:
    sudo apt-get install lib32stdc++6 or
    sudo apt-get install libstdc++6:i386



  • thanks for your help, this bring me in the right way to fix it. Next time i will open my eyes and read the log too :D

    i did a dist-upgrade, now the missing GLIBCXX_3.4.20 is installed. i had only till 3.4.19.

    (at etjump 2.2.0 is a symbol error, like zero said in posts above)


Log in to reply
 

Looks like your connection to ETJump was lost, please wait while we try to reconnect.