Unknown token when hosting a game



  • I'm trying to host a game for offline practice, but for some reason, whenever I try I get this error. Am I missing important files or something? If I am, where do I get them? Do bear in mind that I am NOT trying to host a dedicated server, just a plain, simple, basic one from the host game menu.
    Thanks.



  • Hi!

    Can you post the directory layout of your etjump folder. You need to extract the .zip and the .pk3 in the folder in order to play locally. Here's an example layout that works for me, atleast.

    Dir layout

    What operating system do you use?

    I'll try to figure this out. I've heard complaints from other people too. I have no problems running it, tho :(

    Zero



  • It seems that some people (myself included) have that issue with the newest version of etjump (2.0.5). Until it's figured out, I would suggest using an older version of etjump for playing locally.

    Like Zero already said, you should extract the .zip file into your etjump folder, and then extract the .pk3 file within. Then the folder should look something like the picture Zero posted.

    A .pk3 file is just a renamed .zip file, so you can extract it the same way.

    Edit: Try extracting etjump-2_0_5.pk3 first if you haven't done that yet, in case it works.


  • administrators

    Like said before, you must extract the pk3 into your etjump folder. Make sure you have qagame.mp_x86.dll in the folder.



  • Alright, I did as you guys told me. I extracted everything as you told me to, buy I still get the same error. In response to Zero, the directory where I keep the ETJump folder is C:\Games\Wolfenstein - Enemy Territory\etjump, and this is what my ETJump folder currently looks like:

    EDIT: I just tried what hazz suggested, and I still get the same error. Any suggestions?



  • I'd start with a clean etjump install. Remove/rename the current directory, create a new etjump directory and extract the .zip & .pk3 contents in there.



  • Probably found a fix for this. I'll update the etjump205.zip tomorrow.



  • Hi Zero,

    I am running into the same issue that Tathamet is having.

    I'm running a server locally as follows (via a batch script)

    start etded +setdedicated 0 +set fs_game etjump +set sv_punkbuster 0 +set net_port 27960 +exec tjserver.cfg +set fs_homepath 27960

    The directory layout of my etjump folder is exactly the same as yours.

    (I also tried going into animations/scripts/human_base.script and removing "portalgun" - did not work)
    Any ideas?



  • Ah! I forgot to upload the fixed version to the website. I will do that asap when I get home from work today. Sorry about that.



  • Fixed version should be on the server (http://etjump.com/etjump/etjump-2_0_5.zip)



  • Thanks Zero! Confirmed it's fixed.



  • I am still having the same error, I used the fixed .zip file and unzipped it to the etjump folder of my server, then extracted the contents of the .pk3 file in that same folder.

    http://i.imgur.com/RGcYQPm.png
    http://i.imgur.com/UYjLskQ.jpg



  • @fANAT1C
    Windows version?



  • @Zero said:

    @fANAT1C
    Windows version?

    Yeah, Windows 7 Home Premium 64-bit. Just hosted on my laptop.

    Intel Core 2 Duo T6600 2.2 GHz
    4 GB ram So-DIMM ddr3
    Nvidia GeForce GT 240m 1024 MB
    2x Western Digital Caviar Blue 500 GB @5400 RPM



  • Should work. Delete the folder and redo it. If it does not work I'm afraid I have no solution.



  • I just installed ETJump 2.0.4 on my server and this seems to be working just fine so I will stick with this version until the next release of ETJump. However can you please provide me an example server config for my server?



  • Next version will not suddenly start working if 2.0.5 does not work.

    Slightly outdated example config can be found here: http://etjump.com/etjump/etjump_server_example.cfg
    Check out docs for more info.

    http://etjump.com/documentation


Log in to reply
 

Looks like your connection to ETJump was lost, please wait while we try to reconnect.